Contenido

Validando videos en Strict!

6 jun

+ 12

Inocente de mi! ¿Como podía que creer que no había forma posible de validar en strict los videos de youtube? Menos mal que Jorturos me ha explicado como.

<object style="width:425px; height:350px; display: block; margin: 0 auto;" 
	id="VideoPlayback" type="application/x-shockwave-flash" data="URL del video de YouTube">
	<param name="wmode" value="transparent" />
</object>
  

Facil, facil!! 

Actualizo

Elimino align=”middle” por que no valida, se me había pasado ;)

  • Precisamente ayer escribí un mini-tutorial para poner quicktags y no tener que memorizar/buscar el código siempre que deseemos incluir un video en la web.

  • Magnifico el mini-tutorial de Javi Vicente para validar los videos, desde que corregi el codigo para que pasara el estandar W3C no ponia videos en mi Blog. Gracias a los dos (Andrés y Javi).

  • Un poco exagerdos… eso de no poner videos porque no validan al pie de la letra el W3C. Una cosa es escribir una web con el propósito de que sea validad pero no todo tiene que estar cuidad al pie de la letra, relajaos y vivir un poco anda.

    xDD

  • ¿Ya no te acuerdas que te dije que mi plugin ya metía videos de YouTube que validaban?.

    De todas formas, estoy en plena remodelación, que con los últimos cambios de YouTube la cosa no va fina del todo. Espero sacar la nueva versión hoy o mañana con más novedades.

  • Muy bueno Javi!! Yo tambien me he hecho un plugin para facilitarme el trabajo.

    SKaRCha, si que me acuerdo, pero cuando entré en tu web y vi que usabas transicional (por entonces) creí que lo habías conseguido para esa especificación.

    De todas formas he tenido que modificarlo ya que el atributo aling no esta permitido por strict.

    Show, para que veas hasta que punto queremos ser profesionales xDDD
    Tambien opino que tenemos que ser un poco más humanos y disfrutar, y no comernos la cabeza tanto, pero mis valores no me lo permiten. Ser desarrollador y no poder validar mi propia web me frustra, asi que mientras no encuentro una solución, lo dejo en espera :D

    Un saludo

  • Soy yo o en Internet Explorer no va? :S

  • O.O!!

    P… Explorer xDDD

    Por esto odio IE!! Veremos a ver que podemos montar para que funcionen bien…

  • Ya:

    
    <object type="application/x-shockwave-flash" 
    style="width:408px; height:325px; display: block; margin: 0 auto;"
    data="http://www.youtube.com/v/KTBijeKG1ms">
    <param name="movie" value="http://www.youtube.com/v/KTBijeKG1ms" />
    </object>
    

    http://www.vidablog.com/youtube.html

Comentar

#

Me reservo el derecho de eliminar y/o modificar los comentarios que contengan lenguaje inapropiado, spam u otras conductas no apropiadas en una comunidad civilizada. Si tu comentario no aparece, puede ser que akismet lo haya capturado, cada día lo reviso y lo coloco en su lugar. Siento las molestias.