Contenido

YourTags [Plugin]

2 dic

+ 6

Bueno, los que ya conozcais la version Beta 1 o la Beta 2 (o la RC1) de WordPress, sabreis que el sistema de escribir los posts ha cambiado y ahora es algo más cómodo ya que usa un WYSIWYG (TinyMCE). Pero le he encontrado una serie de limitaciones, bueno más que limitaciones son incomodidades, ya que ahora no disponemos de botones para hacernos la vida más facil a la hora de insertar codigo (<code>) o quotes (<blockquote>).

Entonces he estado pensando en crear un plugin para intentar hacer la vida un poco más facil en este aspecto, permitiendo definir tags para usarlos en el texto.

Caracteríticas

  • Permite activar/desactivar los tags automáticamente mediante Ajax
  • Modificación dinámica mediante Ajax

Intrucciones para instalar:

  • Descoprimir el fichero
  • Subir al FTP a la carpeta /wp-content/plugins/
  • Activar desde el Dashboard
  • Configurar desde Opciones >> YourTags

Ideas

  • [rojo] –> <span style=”color:red”>
  • [/rojo] —></span>

Descargar

  • Estás hecho un fiera tio. Sigue así. ;)

  • Muy bueno el plugin, lo que he probado de WordPress 2.0 le he desactivado el editor WYSIWYG, no me gusta mucho. Al desactivarlo en el panel de opciones, las quictags aparecen como en la versión estable de WordPress.

    De cualquier manera es muy bueno para aquellos que quieren el editor y además unas cuantas quicktags :).

  • Probaste “EditorMonkey” ?yo solucione los problemas de limitacion en el WYSIWYG, es un plugin que tiene muchas opciones, trae incorporado el TinyMCE pero con muchos mas botones y ademas otro que se llama FCKEditor es posible desde opciones–>editor monkey elegir cualquiera de los dos, personalmente prefiero el segundo, te permite añadir codigo y es altamente configurable y funciona mucho mejor que el TnyMCE limitado que trae WP 2.0 incorporado. Ademas podes agregar WYSIWYG a los comentarios, pero no funciona con ajaxRegulus, no obstante para añadir tags por ejemplo o caracterizar las clases de los vinculos (ej: clase GB de graybox) es estupendo ya que no es necesario tipear codigo. Ademas trae un gestor de imagenes mejor que el de WP 2.0 en fin, lo recomiendo, facilita mucho a la hora de postear, sobre todo a aquellos que necesiten muchos tags en sus post.
    Saludos

  • Hola al activar el plug in me salio un error de funcion menu duplicada, lo solucione renombrando esta función, además en el administrador me salio un error en la linea 131, exactamente es el foreach… la verdad no se que problema pueda ser. (Seguramente la versión del PHP de mi servidor v.4)
    A lo mejor suene como un pesado, espero que no sólo era una timida apreciación de este plug in.

Comentar

#

Me reservo el derecho de eliminar y/o modificar los comentarios que contengan lenguaje inapropiado, spam u otras conductas no apropiadas en una comunidad civilizada. Si tu comentario no aparece, puede ser que akismet lo haya capturado, cada día lo reviso y lo coloco en su lugar. Siento las molestias.